Re: [cc65] Hello, and a memory corruption (?) issue when optimizing

From: Ullrich von Bassewitz <uz1musoftware.de>
Date: 2013-06-09 16:45:17
Hi!

On Sun, Jun 09, 2013 at 04:09:56PM +0200, Maik Merten wrote:
> cc65 gave me the opportunity to create usable results somewhat
> quickly, so thanks a lot to everyone involved! I'm sorry to read
> cc65 is currently unmaintained, but thankfully this list still seems
> to exist.

Actually, Oliver stated that he has taken over, including new binaries and a
new mailing list.

> Either way, I notice that the title screen, which displays a
> multicolor bitmap, is corrupted when specifying any of cl65's -O
> options in the Makefile.

Which version of the compiler are you using? 2.13.3 has some problems. The
latest snapshot was a lot better but has been removed from the ftp server on
request. I think Oliver is offering more up-to-date binaries and I would
suggest trying them.

> Can anybody offer advise?

I would first try to determine what causes the corruption. To do that, load
the code into VICE, and write-protect the memory in question. This is done in
the monitor by setting a break-on-write breakpoint if I remember correctly.
Then check which code overwrites the image.

Regards


        Uz


-- 
Ullrich von Bassewitz                                  uz@musoftware.de
----------------------------------------------------------------------
To unsubscribe from the list send mail to majordomo@musoftware.de with
the string "unsubscribe cc65" in the body(!) of the mail.
Received on Sun Jun 9 16:45:23 2013

This archive was generated by hypermail 2.1.8 : 2013-06-15 17:37:38 CEST