Re: [cc65] Hello, and a memory corruption (?) issue when optimizing

From: Oliver Schmidt <ol.sc1web.de>
Date: 2013-06-22 18:44:44
Hi Uz,

> I had some time to look into the issue, and think that the following patch
> should fix the problem: [...]

Oh, what a very nice surprise :-))

I was extremely tempted to ask you to look into the issue as it was
pretty clear that it would stay in place otherwise. However I felt
that fixing bugs was most likely not what you liked most about your
work on cc65 ;-)

And maybe it's worth mentioning at this point that you're explicitly
invited to participate as contributor in "cc65@GitHub" - i.e. by
subscribing to the mailing list mentioned there.

> Please note that I haven't done many tests, but the changes seem pretty safe,
> since if they're triggered when they shouldn't all that happens is that code
> is left in place that could be removed.

I'm currently working on building automatic regression tests based on
Stefans testsuite. As currently nobody is suffering from the bug in
question - the OP has a known workaround afaik - I plan to first get
the regression tests set up and to apply the patch afterwards.

I'll of course provide feedback here on the results.

Regards,
Oliver
----------------------------------------------------------------------
To unsubscribe from the list send mail to majordomo@musoftware.de with
the string "unsubscribe cc65" in the body(!) of the mail.
Received on Sun Jun 23 11:09:33 2013

This archive was generated by hypermail 2.1.8 : 2013-06-23 11:09:34 CEST